1. 程式人生 > >HDU 6335 Nothing is Impossible 貪心

HDU 6335 Nothing is Impossible 貪心

Problem Description
m students, including Kazari, will take an exam tomorrow.
The paper consists of exactly n problems, the i-th problem contains ai correct answers and bi incorrect answers, i.e. the i-th problem contains ai+bi candidates in total.
Each student should choose exactly one candidate as answer for each problem. If the answer to a certain problem is correct, then the student will get one point. The student who gets the most points wins.
Students only know the structure of the paper, but they are able to talk with each other during the exam. They decide to choose a subset S of all n problems, and they will only be able to submit answers on these problems.
They want to know the maximum size of S that the winner among them will solve all the problems in S if they take the optimal strategy.

For sample 1, students can choose S={1},and we need at least 4 students to guarantee the winner solve the only problem.

For sample 2, students can choose S={1,2,3}, and we need at least 24 students to guarantee the winner solve these three problems, but if |S|=4, we need at least 96 students, which is more than 50.
 

Input
The first line of the input contains an integer T (1≤T≤100) denoting the number of test cases.
Each test case starts with two integers n,m (1≤n≤100,1≤m≤109), denoting the number of problems and the number of students. Each of next n lines contains two integers ai,bi (1≤bi≤100,ai=1), indicating the number of correct answers and the number of incorrect answers of the i-th problem.
 

Output
For each test case, print an integer denoting the maximum size of S.
 

Sample Input
2    
3 5
1 3
1 3
1 3
5 50
1 1
1 3
1 2
1 3
1 5
 

Sample Output
1
3

題意:很生澀難道,n個題目,m個人,然後n個題目 a個正確答案 b個錯誤答案,答對一題得一分 求m個人最多可以得到多少分

思路:將錯誤答案數從小到大排列,每個題目最少要 錯誤答案數+1 個人 才可能正確。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 1005;
ll a[N];
int main()
{
    int t,n,m;
    cin >> t;
    while(t--)
    {
        cin >> n >> m;
        for(int i=0;i<n;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            a[i]=y+1;
        }
        sort(a,a+n);
        int i;
        ll sum=1,num=0;
        for(i=0;i<n;i++)
        {
            if(sum*a[i]<=m){
                sum=sum*a[i];
                num++;
            }
            else
                break;
        }
        cout<<num<<endl;
    }

    return 0;
}