1. 程式人生 > >C++動態規劃演算法之Maximum sum(最大和)

C++動態規劃演算法之Maximum sum(最大和)

Maximum sum(最大和)

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
                     t1     t2 
         d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
                    i=s1   j=s2

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
OutputPrint exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

Source

POJ Contest,Author:[email protected]

大意

給定一組N個整數:A ={A1,A2,...,An},我們定義一個函式D(A)如下:
……


你的任務是計算d(A)。輸入包括T(<=30)的測試資料。
測試資料的數目T,在輸入的第一行。每個測試用例包含兩個行。
第一行是整數N(2<= N <=50000)。
第二行包含N個整數:A1,A2,...,An。 (|Ai|<=10000)。每個案例後有一個空行。列印每個測試用例只有一個行,該行應包含整數d(A)。
在示例中,我們選擇{2,2,3,-3,4}和{5},那麼我們就可以得到答案。

解題

看到這道題時,我想到了兩種方法——深搜(TLE)、動態規劃(AC)。

方法壹:深搜

狀態:

#include<bits/stdc++.h>
using namespace std;
int maxn,sum,n,a[50001];
bool flag=1;    //用於判斷是否截了第二段數
void dfs(int x)
{
	if(x<=n) //判斷是不是列舉完了所有數
	{
		sum+=a[x];
		if(flag) //判斷是否截了第二段數
		{
			flag=0;
			for(int j=x+1;j<=n;j++)dfs(j); //列舉第二段數起始位置
			flag=1;
		}
		dfs(x+1);
		if(!flag)maxn=max(sum,maxn); //if用於判斷是不是截了兩段數
		sum-=a[x]; //回溯
	}
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i=1;i<=n;i++) cin>>a[i];
		for(int i=1;i<=n;i++) dfs(i); //列舉第一段數起始位置
		cout<<maxn<<endl;
	}
}

方法貳:動態規劃

狀態:

#include<bits/stdc++.h>
using namespace std;
int n,maxn,a[50001],f[50001],g[50001],F[50001],G[50001];
main()
{
	int t;
	cin>>t;
	while(t--)
	{
		maxn=-20001;
		cin>>n>>a[1];
		int mxf=F[1]=f[1]=a[1];
		for(int i=2;i<=n;i++)
		{
			cin>>a[i];
			f[i]=a[i]+max(0,f[i-1]);    //找出在a[1]……a[i]序列中以a[i]為結尾的和最大子序列
			mxf=F[i]=max(mxf,f[i]); //找出在a[1]……a[i]序列中的和最大子序列(不一定包含a[i])
		}
		int mxg=G[n]=g[n]=a[n];
		for(int i=n-1;i>0;i--)
		{
			g[i]=a[i]+max(0,g[i+1]);    //找出在a[i]……a[n]序列中以a[i]為開頭的和最大子序列
			mxg=G[i]=max(mxg,g[i]); //找出在a[i]……a[n]序列中的和最大子序列(不一定包含a[i])
		}
		for(int i=1;i<n;i++)        //列舉斷點
			if(F[i]+G[i+1]>maxn) //G[i+1]是因為不可有重疊部分
				maxn=F[i]+G[i+1];
		cout<<maxn<<endl;
	}
}