1. 程式人生 > >POJ 2299 分治法求數列逆序對(歸併排序)

POJ 2299 分治法求數列逆序對(歸併排序)

Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 50482 Accepted: 18516

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0

題意:
求一個序列的逆序對數。
題解:
這題是可以用分治做的。我們考慮把一個序列分成兩部分。那這個序列的逆序對數就等與每一部分的逆序對數加上合併的逆序對數,比如我們在s1(2,3,5)和s2(1,4)兩個序列,當拿1時,可以知道它和s1裡的三個數組合的都是逆序對。接著拿2,3.當拿到4時,4和5是逆序,如此一來,如果s1和s2是有序的。那麼在歸併排序合併時就能直接算出來有多少對逆序數。時間複雜度就是歸併排序的時間複雜度,時間上界為O(nlogn)

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define SIZE  500000
#define f(i,a,b) for(int i = a;i<=b;i++)
#define fi(i,a,b) for(int i = a;i>=b;i--)

using namespace std;

int a[SIZE];
int b[SIZE];

long long Merge(int low,int mid,int high){
    long long sum = 0;
    int s = low,t = mid + 1,k = low;
    while(s<=mid&&t<=high){
        if(a[s]<a[t]){
            b[k] = a[s++];
        }else{
            sum+=mid-low+1-(s-low);
            b[k] = a[t++];
        }
        k++;
    }

    if(s == mid+1) f(i,k,high) b[i] = a[t++];
    else f(i,k,high) b[i] = a[s++];

    f(i,low,high) a[i] = b[i];

    return sum;
}

long long MergeSort(int low,int high){
    if(low<high){
        int mid = (low+high)/2;
        long long k1 = MergeSort(low,mid);
        long long k2 = MergeSort(mid+1,high);
        long long k3 = Merge(low,mid,high);
        return k1+k2+k3;
    }
    else
        return 0;
}

int main()
{
    int n;
    while(scanf("%d",&n)&&n){
        f(i,1,n) scanf("%d",&a[i]);
        printf("%lld\n",MergeSort(1,n));
    }
    return 0;
}