1. 程式人生 > >HDU 1081 最大子陣和

HDU 1081 最大子陣和

Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 


As an example, the maximal sub-rectangle of the array: 


0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 


is in the lower left corner: 


9 2 
-4 1 
-1 8 


and has a sum of 15. 
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127]. 
Output
Output the sum of the maximal sub-rectangle. 
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output

15

//DP問題
//與最大子列和類似,可以看做是一維最大子串和的二維擴充套件
#include <stdio.h>
#include <stdlib.h>
int main()
{
    int dp[101][101];//dp[i][j]指的是第i行前j個元素的和
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++){
             int t;
             scanf("%d",&t);
             dp[i][j]=dp[i][j-1]+t;//此段程式碼簡化了限定列範圍以後求當前行 列範圍內 元素和的複雜度,化O(N)為O(1)
          }
        int max=0;
        for(int i=1;i<=n;i++){//i,j限定列的左右範圍
            for(int j=i;j<=n;j++){
                int sum=0;
                for(int t=1;t<=n;t++){//遍歷行,此處的思想等同於一維了
                    sum+=dp[t][j]-dp[t][i-1];//限定列範圍以後,當前行  列範圍內 元素和
                    if(sum<0)
                        sum=0;
                    else if(sum>max)
                        max=sum;
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}