1. 程式人生 > >hdu 1081 (最大子矩陣和)dp To The Max

hdu 1081 (最大子矩陣和)dp To The Max

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2

is in the lower left corner:

9 2 -4 1 -1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2

Sample Output

15 題意:題目不難理解呀。就是給你一個nn的矩陣,讓你找出和最大的子矩陣來。 這種題原來做過,好久沒看了,忘了。。。。大體的思路就是先將原來矩陣每一行的數存到一個nn的字首和數組裡。然後控制列數,移動行數,這樣來找尋最大子矩陣。有的題解說這樣是二維壓縮成一維,我也不太明白。反正思路明白就好了。 程式碼如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;

int a[101][101];
int n;
int temp;

int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&temp);
				a[i][j]=a[i][j-1]+temp;
			}
		}
		int ans=-inf;
		int res=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=i;j<=n;j++)
			{
				for(int k=1,res=0;k<=n;k++)//每次行數從頭開始的時候就要將res更新為0
				{
					res+=(a[k][j]-a[k][i-1]);
					if(res<0) res=0;//res小於0時,res就要更新為零!!!
					ans=max(ans,res);
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

努力加油a啊,(o)/~