1. 程式人生 > >hdu 2544(最短路)

hdu 2544(最短路)

Problem Description 在每年的校賽裡,所有進入決賽的同學都會獲得一件很漂亮的t-shirt。但是每當我們的工作人員把上百件的衣服從商店運回到賽場的時候,卻是非常累的!所以現在他們想要尋找最短的從商店到賽場的路線,你可以幫助他們嗎?


Input 輸入包括多組資料。每組資料第一行是兩個整數N、M(N<=100,M<=10000),N表示成都的大街上有幾個路口,標號為1的路口是商店所在地,標號為N的路口是賽場所在地,M則表示在成都有幾條路。N=M=0表示輸入結束。接下來M行,每行包括3個整數A,B,C(1<=A,B<=N,1<=C<=1000),表示在路口A與路口B之間有一條路,我們的工作人員需要C分鐘的時間走過這條路。
輸入保證至少存在1條商店到賽場的路線。

Output 對於每組輸入,輸出一行,表示工作人員從商店走到賽場的最短時間
Sample Input 2 1 1 2 3 3 3 1 2 5 2 3 5 3 1 2 0 0
Sample Output 3 2

Dijkstra模板(最短路)

<pre name="code" class="cpp">void ShortestPath()  
{  
    int i, j, u, temp, newdist;  
    if (v<1 || v>n)    return;  
    for (i=1; i<= n; i++)  
    {  
        dist[i] = a[v][i];  
        s[i] = 0;  
    }  
    dist[v] = 0, s[v] = 1;  
    for (i = 2; i <= n; i++)  
    {  
        temp = MAX;  
        u = v;  
        for (j = 1; j <= n; j++)  
            if ((!s[j])&&(dist[j]<temp))  
            {  
                u = j;  
                temp = dist[j];  
            }  
        s[u] = 1;  
        for (int j = 1; j <= n; j++)  
            if((!s[j])&&(a[u][j]<MAX))  
            {  
                newdist = dist[u]+a[u][j];  
                if (newdist<dist[j])    dist[j] = newdist;  
            }  
    }  
}
v在主函式裡初始化為1,表示從1開始的最短路dist[i]表示從1到 i 的最短路a[ ][ ]是個二元陣列,a[ i ][ j ]=w表示i 到 j 的路徑長度為 w.#define MAX 0x7fffffff一般先在主函式裡把所有的a[ ][ ]置為無窮大(MAX),表示所有路都不通。s[ ]為一元陣列,若s[ i ]=1表示 i 被劃在粗線內,s[ i ]=0反之。
具體原理網上很多。

貼上此題程式碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#define MAX 0x7fffffff
using namespace std;

int a[105][105],dist[105],s[105];
int v,m,n;
void ShortestPath()
{
    int i, j, u, temp, newdist;
    if (v<1 || v>n)    return;
    for (i=1; i<= n; i++)
    {
        dist[i] = a[v][i];
        s[i] = 0;
    }
    dist[v] = 0, s[v] = 1;
    for (i = 2; i <= n; i++)
    {
        temp = MAX;
        u = v;
        for (j = 1; j <= n; j++)
            if ((!s[j])&&(dist[j]<temp))
            {
                u = j;
                temp = dist[j];
            }
        s[u] = 1;
        for (int j = 1; j <= n; j++)
            if((!s[j])&&(a[u][j]<MAX))
            {
                newdist = dist[u]+a[u][j];
                if (newdist<dist[j])    dist[j] = newdist;
            }
    }
}

int main()
{
    while(cin>>n>>m&&!(n==0&&m==0))
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
            a[i][j]=MAX;
        for(int i=0;i<m;i++)
        {
            int x,y,z;
            cin>>x>>y>>z;
            a[x][y]=a[y][x]=z;
        }
        v=1;
        ShortestPath();
        cout<<dist[n]<<endl;
    }
    return 0;
}