1. 程式人生 > >PAT 甲級 1007 Maximum Subsequence Sum(線上處理演算法優化)

PAT 甲級 1007 Maximum Subsequence Sum(線上處理演算法優化)

1007 Maximum Subsequence Sum (25)(25 分)

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Analysis:

Maximum Subsequence Sum is a classic problem, which can be sovled in O(n).

but what you need to pay attention to is that  if the largest number is 0,you should not print "0,a[0],a[n-1]",instead,"0 0 0"is true answer.  

c++

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	freopen("1007 Maximum Subsequence Sum.txt","r",stdin);
	int n,sum=0,j=0,count=0,len=0,flag=true;
	long long max=0;  
	cin>>n;
	int a[n];
	for(int i=0;i<n;i++){
		cin>>a[i];
		if(a[i]>=0)flag=false;		
	}

	for(int i=0;i<n;i++){
		sum+=a[i];
		len++;//record the current length
		if(sum<0){
			sum=0;
			len=0;	
		}
		else if(sum>max){//find a lager Subsequence	
			j=i;//record the last  index
			count=len;//record the length
			max=sum;//revise
		}
	}
	if(flag)
		printf("0 %d %d",a[0],a[n-1]);
	else if(max==0)
		printf("0 0 0");
	else
		printf("%lld %d %d",max,a[j-count+1],a[j]);
	return 0;
}