1. 程式人生 > >HDU 1848(sg博弈) Fibonacci again and again

HDU 1848(sg博弈) Fibonacci again and again

ace main esp 數量 mode oid else while n)

Fibonacci again and again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6253 Accepted Submission(s): 2603


Problem Description 不論什麽一個大學生對菲波那契數列(Fibonacci numbers)應該都不會陌生,它是這樣定義的:
F(1)=1;
F(2)=2;
F(n)=F(n-1)+F(n-2)(n>=3);
所以,1,2,3,5,8,13……就是菲波那契數列。
在HDOJ上有不少相關的題目,比方1005 Fibonacci again就是以前的浙江省賽題。
今天,又一個關於Fibonacci的題目出現了,它是一個小遊戲。定義例如以下:
1、 這是一個二人遊戲;
2、 一共同擁有3堆石子。數量各自是m, n, p個;
3、 兩人輪流走;
4、 每走一步能夠選擇隨意一堆石子,然後取走f個;
5、 f僅僅能是菲波那契數列中的元素(即每次僅僅能取1,2,3,5。8…等數量);
6、 最先取光全部石子的人為勝者;

如果兩方都使用最優策略。請推斷先手的人會贏還是後手的人會贏。



Input 輸入數據包括多個測試用例。每一個測試用例占一行。包括3個整數m,n,p(1<=m,n,p<=1000)。
m=n=p=0則表示輸入結束。

Output 假設先手的人能贏,請輸出“Fibo”,否則請輸出“Nacci”。每一個實例的輸出占一行。



Sample Input
1 1 1
1 4 1
0 0 0

Sample Output
Fibo
Nacci

Author lcy
Source ACM Short Term Exam_2007/12/13
Recommend lcy | We have carefully selected several similar problems for you: 1850 1846 2147 1517 1404




經典的SG 博弈。

我們算出sg的值。,用三堆石頭的sg值異或,假設為0則後手勝,不為0則先手勝。


#include  <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <iostream>
#include <cstdio>
using namespace std;
int hash1[1005];
int sg[1005];
int f[1005];
void getsg(int x)
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1; i<=x; i++)
    {
        memset(hash1,0,sizeof(hash1));
        for(j=1; f[j]<=i; j++)
        {
            hash1[sg[i-f[j]]]=1;
        }
        for(j=0; j<=x; j++)
        {
            if(!hash1[j])
            {
                sg[i]=j;
                break;
            }
        }
    }
}
int main()
{
    f[1]=1;
    f[2]=2;
    for(int i=3;; i++)
    {
        f[i]=f[i-1]+f[i-2];
        if(f[i]>1000)
            break;
    }
    int m,n,p;
    getsg(1000);
    while(cin>>m>>n>>p,m,n,p)
    {
        if((sg[m]^sg[n]^sg[p])==0)
            cout<<"Nacci"<<endl;
        else
            cout<<"Fibo"<<endl;
    }
    return 0;
}

HDU 1848(sg博弈) Fibonacci again and again