1. 程式人生 > >HDU 5389 Zero Escape(dp啊 多校)

HDU 5389 Zero Escape(dp啊 多校)

white pla bold name lan ems popu orm fin

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?

pid=5389


Problem Description Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft.

Stilwell is enjoying the first chapter of this series, and in this chapter digital root is an important factor.

This is the definition of digital root on Wikipedia:
The digital root of a non-negative integer is the single digit value obtained by an iterative process of summing digits, on each iteration using the result from the previous iteration to compute a digit sum. The process continues until a single-digit number is reached.
For example, the digital root of
65536 is 7, because 6+5+5+3+6=25 and 2+5=7.

In the game, every player has a special identifier. Maybe two players have the same identifier, but they are different players. If a group of players want to get into a door numbered X(1X9), the digital root of their identifier sum must be
X.
For example, players {1,2,6} can get into the door 9, but players {2,3,3} can‘t.

There is two doors, numbered A and B. Maybe A=B, but they are two different door.
And there is n players, everyone must get into one of these two doors. Some players will get into the door A, and others will get into the door
B.
For example:
players are {1,2,6}, A=9, B=1
There is only one way to distribute the players: all players get into the door 9. Because there is no player to get into the door 1, the digital root limit of this door will be ignored.

Given the identifier of every player, please calculate how many kinds of methods are there, mod 258280327.
Input The first line of the input contains a single number T, the number of test cases.
For each test case, the first line contains three integers n, A and B.
Next line contains n integers idi, describing the identifier of every player.
T100, n105, n106, 1A,B,idi9
Output For each test case, output a single integer in a single line, the number of ways that these n players can get into these two doors.
Sample Input
4
3 9 1
1 2 6
3 9 1
2 3 3
5 2 3
1 1 1 1 1
9 9 9
1 2 3 4 5 6 7 8 9

Sample Output
1
0
10
60

Source

field=problem&key=2015+Multi-University+Training+Contest+8&source=1&searchmode=source" style="color:rgb(26,92,200); text-decoration:none">2015 Multi-University Training Contest 8


題意:(轉)

一個長度為 n 的序列分為兩組,使得一組的和為A,一組的和為B.

求有多少種分法!

PS:

註意這裏的和定義為這些數的和的數根。

一個數的數根的計算公式為,root = (x-1)%9+1;

非常明顯一個正整數的數根是1~9的分析,假設這n個數的數根分成兩組使得

一組的數根為A,一組的數根為B那麽這兩組的數的和的數根等於(A+B)的

數根。

因此我們僅僅須要考慮組成當中一個數的情況。然後再最後進行一個

推斷就可以我們設dp[i][j]表示前i個數組成的數根為j的數目。

註意當中隨意一組能夠為空。

代碼例如以下:

#include <cstdio>
#include <cstring>
const int mod = 258280327;
#define maxn 100017
int dp[maxn][10];
//dp[i][j]:前i個數能組成j的方案數

int num[maxn];
int cal(int x, int y)
{
    int tmp = x+y;
    int ans = tmp%9;
    if(ans == 0)
    {
        return 9;
    }
    return ans;
}
int main()
{
    int t;
    int n, a, b;
    scanf("%d",&t);
    while(t--)
    {
        int sum = 0;
        memset(dp,0,sizeof(dp));
        scanf("%d%d%d",&n,&a,&b);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&num[i]);
            sum = cal(sum,num[i]);
        }
        dp[0][0] = 1;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j <= 9; j++)
            {
                dp[i][j]+=dp[i-1][j];
                dp[i][j]%=mod;
                int tt = cal(num[i],j);
                dp[i][tt]+=dp[i-1][j];
                dp[i][tt]%=mod;
            }
        }
        int ans = 0;
        if(cal(a, b) == sum)
        {
            ans+=dp[n][a];
            if(a == sum)
            {
                ans--;
            }
        }
        if(sum == a)//都分給a
        {
            ans++;
        }
        if(sum == b)//都分給b
        {
            ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


HDU 5389 Zero Escape(dp啊 多校)