1. 程式人生 > >POJ3624 Charm Bracelet 【01背包】

POJ3624 Charm Bracelet 【01背包】

%d who ace char tdi integer color 背包 let

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22621 Accepted: 10157

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N

(1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

題意:給定物品數量n和背包容量m,n個物品的重量weight和價值val,求能獲得的最大價值。

題解:狀態轉移方程:dp[i][j] = max(dp[i-1][j], dp[i-1][j-w[i]] + v[i]);當中狀態dp[i][j]表示前i個物品放在容量為j的背包中能獲得的最大價值。

二維數組能夠壓縮成一維以節省空間,可是內層循環須要倒序。

原始版本號:耗時360ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight) dp[j] = max(dp[j], dp[j - weight] + val);
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}<span style="font-family:FangSong_GB2312;">
</span>

優化後的代碼:耗時219ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight && dp[j - weight] + val > dp[j]) 
				dp[j] = dp[j - weight] + val;
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}

用二維dp數組寫了一個,果斷的超了內存,占用內存大概12882*3404*4/1024=171兆。題目限制是65兆

TLE:

#include <stdio.h>
#define maxn 12882

int dp[3404][maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, m, weight, val, i, j;
    scanf("%d%d", &n, &m);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = 1; j <= m; ++j)
            if(j >= weight)
                dp[i][j] = max(dp[i-1][j], dp[i-1][j-weight] + val);
            else dp[i][j] = dp[i-1][j];
    }
    printf("%d\n", dp[n][m]);
    return 0;
}



POJ3624 Charm Bracelet 【01背包】