1. 程式人生 > >HDU2389:Rain on your Parade(二分圖最大匹配+HK演算法)

HDU2389:Rain on your Parade(二分圖最大匹配+HK演算法)

Rain on your Parade

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
Total Submission(s): 5755    Accepted Submission(s): 1900

Description:

You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
Can you help your guests so that as many as possible find an umbrella before it starts to pour?

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.

Input:

The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si

<= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
The absolute value of all coordinates is less than 10000.

Output:

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.

Sample Input:

2
1
2
1 0 3
3 0 3
2
4 0
6 0
1
2
1 1 2
3 3 2
2
2 2
4 4

Sample Output:

Scenario #1:
2

Scenario #2:
2

題意:

給出客人和雨傘的二維座標,知道幾分鐘後下雨以及客人的移動速度,問可以拿到雨傘最多有多少人。

 

題解:

將客人與其可以到達的雨傘連邊,進行二分圖的最大匹配即可。

但這題比較坑的地方就是資料量較大,匈牙利演算法會超時(好像很少有題會卡匈牙利演算法........),所以就應該用匈牙利演算法的優化版:HK演算法。

HK演算法的思想就是先通過bfs預處理出最小增光路集,然後dfs增廣的時候就把這些增廣路集一併增廣。

具體的演算法分析可以看看這個:http://files.cnblogs.com/files/liuxin1.pdf

 

直接上程式碼~~

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue> 
using namespace std;
const int N = 3005 ;
int T,t,n,m,ans,lim,cnt=0;
int d[N][N],link[N][N],match[N],match2[N],check[N],disx[N],disy[N];
struct guests{
    int x,y,v;
}g[N];
inline void init(){
    memset(link,0,sizeof(link));memset(match,-1,sizeof(match));
    ans=0;cnt++;memset(check,0,sizeof(check));memset(match2,-1,sizeof(match2));
}
inline int dfs(int x){
    for(int i=1;i<=n;i++){
        if(disy[i]==disx[x]+1 && !check[i] &&link[x][i]){
            check[i]=1;
            if(match[i]!=-1 && disy[i]==lim) continue ;//此時增廣路會大於lim 
            if(match[i]==-1 || dfs(match[i])){
                match[i]=x;
                match2[x]=i;
                return 1;
            }
        }
    }
    return 0;
}
inline bool bfs(){
    queue<int> q;
    memset(disx,-1,sizeof(disx));
    memset(disy,-1,sizeof(disy));lim = (1<<30);
    for(int i=1;i<=m;i++) if(match2[i]==-1){
        q.push(i);disx[i]=0;
    }
    while(!q.empty()){
        int u=q.front();q.pop();
        if(disx[u]>lim) break ; //條件成立,所求增廣路必然比當前的增廣路長度長 
        for(int i=1;i<=n;i++){
            if(link[u][i] && disy[i]==-1){
                disy[i]=disx[u]+1;
                if(match[i]==-1) lim=disy[i];//找到增廣路,記錄長度 
                else{
                    disx[match[i]]=disy[i]+1;
                    q.push(match[i]);//入隊,尋找更長的增廣路 
                }
            }
        }
    }
    return lim!=(1<<30) ;
}
int main(){
    scanf("%d",&T);
    while(T--){
        init();
        scanf("%d%d",&t,&m);
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&g[i].x,&g[i].y,&g[i].v);
        }
        scanf("%d",&n);
        for(int i=1,x,y;i<=n;i++){
            scanf("%d%d",&x,&y);
            for(int j=1;j<=m;j++){
                d[j][i]=abs(g[j].x-x)+abs(g[j].y-y);
                if(d[j][i]<=t*g[j].v) link[j][i]=1;
            }
        }
        while(bfs()){
            memset(check,0,sizeof(check));
            for(int i=1;i<=m;i++){
                if(dfs(i)) ans++;
            }
        }
        printf("Scenario #%d:\n%d\n\n",cnt,ans);
    }
    
    return 0;
}