1. 程式人生 > >Conquer a New Region(並查集+貪心)

Conquer a New Region(並查集+貪心)

並查集:

Conquer a New Region

Time Limit: 5 Seconds      Memory Limit: 32768 KB

The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

題目大意:

就是從一個點開始到其他的所有點,然後價值是路徑上的最短邊的總和。求這個最大值。

解題思路:

按邊排序,從大到小插入,每條邊將兩個集合連起來,而新加的邊是兩個集合所有邊最小的,那麼兩個集合中的點交叉的通路最小的邊就是新加的,那隻要列舉兩個集合,a,b是a併入b更優還是b併入a更優就行了。集合內部點已經計算出,相互的只要知道集合中元素的個數就好了。

所以並查集只需要維護一個集合的元素個數,一個集合的總權值

本文來自:

時間有限,程式碼就不敲了。

程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 200005
#define MOD 1000000007
#define LL long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct Node
{
    int u,v,w;
    bool operator< (const Node n1) const
    {
        return w>n1.w;
    }
}edge[N];
int cnt[N],pre[N];
LL sum[N];
int find(int a)
{
    return pre[a]=(a==pre[a]?a:find(pre[a]));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
        }
        sort(edge,edge+n-1);
        for(int i=1;i<=n;i++)
        {
            sum[i]=0;
            pre[i]=i;
            cnt[i]=1;
        }
        LL ans=0;
        for(int i=0;i<n-1;i++)
        {
            int ra=find(edge[i].u);
            int rb=find(edge[i].v);
            LL atob=(LL)cnt[ra]*edge[i].w+sum[rb];
            LL btoa=(LL)cnt[rb]*edge[i].w+sum[ra];
            if(atob>btoa)
            {
                pre[ra]=rb;
                cnt[rb]+=cnt[ra];
                sum[rb]=atob;
            }
            else
            {
                pre[rb]=ra;
                cnt[ra]+=cnt[rb];
                sum[ra]=btoa;
            }
            ans=max(ans,max(atob,btoa));
        }
        printf("%lld\n",ans);
    }
    return 0;
}