1. 程式人生 > >HDU 2669 Romantic【擴充套件歐幾里得】

HDU 2669 Romantic【擴充套件歐幾里得】

The Sky is Sprite.  The Birds is Fly in the Sky.  The Wind is Wonderful.  Blew Throw the Trees  Trees are Shaking, Leaves are Falling.  Lovers Walk passing, and so are You.  ................................Write in English class by yifenfei   Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!  Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases.  Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

題解:

擴充套件歐幾里得定理:對於任意整數  a, b,都存在 x, y 是的 ax + by = gcd(a, b)。

對於一般的方程 ax + by = c,它有解當且僅當 d|c,而本題的 c 等於1,所以d也要等於1才有解。無解輸出 “sorry”。並且要求的解 x 必須大於等於0,所以又需要用到通解公式: x = (c/d)x + (b/d)k, y = (c/d)y - (a/d)k, k 為任意整數。

#include <iostream>
#include <cstdio>
#define ll long long
using namespace std;

int exgcd(int a, int b, int &x, int &y){
    if(b == 0){
        x = 1, y = 0;
        return a;
    }
    int d = exgcd(b, a%b, x, y);
    int z = x;
    x = y, y = z - (a/b) * y;
    return d;
}
int main()
{
    int a, b;
    while(cin >> a >> b){
        int x, y;
        int d = exgcd(a, b, x ,y);
        if(d != 1){
            cout << "sorry" << endl;
        }else{
            while(x < 0){
                x += b;
                y -= a;
            }
            cout << x << " " << y << endl;
        }
    }
    return 0;
}