1. 程式人生 > >The Euler function(hdoj2824)(快速求尤拉函式)

The Euler function(hdoj2824)(快速求尤拉函式)

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4757    Accepted Submission(s): 1990


Problem Description The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
Input There are several test cases. Each line has two integers a, b (2<a<b<3000000).
Output Output the result of (a)+ (a+1)+....+ (b)
Sample Input 3 100
Sample Output 3042同樣是快速求尤拉函式的題,與Poj2478基本相同沒什麼好說的。
#include<stdio.h>
#define N 3000005
int phi[N];
int euler()
{
	int i,j;
	for(i=1;i<=N;i++)
	phi[i]=i;
	for(i=2;i<=N;i++)
	{
		if(phi[i]==i)
		{
			for(j=i;j<=N;j+=i)
			{
				phi[j]=phi[j]/i*(i-1);
			}
		}
	} 
}
int main()
{
	int a,b;
	long long sum;
	euler();
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		sum=0;
		for(int i=a;i<=b;i++)
		{
			sum+=phi[i];
		}
		printf("%lld\n",sum);
	}
}