1. 程式人生 > >BZOJ 1031 [JSOI2007]字符加密Cipher (後綴數組)

BZOJ 1031 [JSOI2007]字符加密Cipher (後綴數組)

問題 time rip air tput 數據 pan gre brush

1031: [JSOI2007]字符加密Cipher

Time Limit: 10 Sec Memory Limit: 162 MB
Submit: 7593 Solved: 3291
[Submit][Status][Discuss]

Description

  喜歡鉆研問題的JS同學,最近又迷上了對加密方法的思考。一天,他突然想出了一種他認為是終極的加密辦法 :把需要加密的信息排成一圈,顯然,它們有很多種不同的讀法。例如下圖,可以讀作:

技術分享

JSOI07 SOI07J OI07JS I07JSO 07JSOI 7JSOI0把它們按照字符串的大小排序:07JSOI 7JSOI0 I07JSO JSOI07 OI07JS SOI07J讀出最後一列字符:I0O7SJ,就是加密後的字符串(其實這個加密手段實在很容易破解,鑒於這是 突然想出來的,那就^^)。但是,如果想加密的字符串實在太長,你能寫一個程序完成這個任務嗎?

Input

  輸入文件包含一行,欲加密的字符串。註意字符串的內容不一定是字母、數字,也可以是符號等。

Output

  輸出一行,為加密後的字符串。

Sample Input

JSOI07

Sample Output

I0O7SJ

HINT

對於100%的數據字符串的長度不超過100000。

Source

析:用後綴數組存儲的兩次字符串,然後只要的按字典序輸出答案就好。

代碼如下:

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#include <sstream>
#include <list>
#include <assert.h>
#include <bitset>
#include <numeric>
#define debug() puts("++++")
#define gcd(a, b) __gcd(a, b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define fi first
#define se second
#define pb push_back
#define sqr(x) ((x)*(x))
#define ms(a,b) memset(a, b, sizeof a)
#define sz size()
#define pu push_up
#define pd push_down
#define cl clear()
#define all 1,n,1
#define FOR(i,x,n)  for(int i = (x); i < (n); ++i)
#define freopenr freopen("in.txt", "r", stdin)
#define freopenw freopen("out.txt", "w", stdout)
using namespace std;

typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const LL LNF = 1e17;
const double inf = 1e20;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 2e5 + 10;
const int maxm = 3e5 + 10;
const ULL mod = 3;
const int dr[] = {-1, 0, 1, 0};
const int dc[] = {0, -1, 0, 1};
const char *de[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline bool is_in(int r, int c) {
  return r >= 0 && r < n && c >= 0 && c < m;
}

struct Array{
  int s[maxn], sa[maxn], t[maxn], t2[maxn];
  int h[maxn], r[maxn], c[maxn];
  int n;

  void init(){ n = 0;  memset(sa, 0, sizeof sa); }
  void build_sa(int m){
    int *x = t, *y = t2;
    for(int i = 0; i < m; ++i)  c[i] = 0;
    for(int i = 0; i < n; ++i)  ++c[x[i] = s[i]];
    for(int i = 1; i < m; ++i)  c[i] += c[i-1];
    for(int i = n-1; i >= 0; --i)  sa[--c[x[i]]] = i;

    for(int k = 1; k <= n; k <<= 1){
      int p = 0;
      for(int i = n-k; i < n; ++i)  y[p++] = i;
      for(int i = 0; i < n; ++i)  if(sa[i] >= k)  y[p++] = sa[i] - k;
      for(int i = 0; i < m; ++i)  c[i] = 0;
      for(int i = 0; i < n; ++i)  ++c[x[y[i]]];
      for(int i = 1; i < m; ++i)  c[i] += c[i-1];
      for(int i = n-1; i >= 0; --i)  sa[--c[x[y[i]]]] = y[i];

      swap(x, y);
      p = 1;  x[sa[0]] = 0;
      for(int i = 1; i < n; ++i)
        x[sa[i]] = y[sa[i-1]] == y[sa[i]] && y[sa[i-1]+k] == y[sa[i]+k] ? p-1 : p++;
      if(p >= n)  break;
      m = p;
    }
  }

  void getHight(){
    int k = 0;
    for(int i = 0; i < n; ++i)  r[sa[i]] = i;
    for(int i = 0; i < n; ++i){
      if(k)  --k;
      int j = sa[r[i]-1];
      while(s[i+k] == s[j+k])  ++k;
      h[r[i]] = k;
    }
  }

};
char s[maxn];
Array arr;

int main(){
  scanf("%s", s);
  arr.init();
  for(int i = 0; s[i]; ++i, ++n)  arr.s[arr.n++] = s[i];
  for(int i = 0; s[i]; ++i)  arr.s[arr.n++] = s[i];
  arr.s[arr.n++] = 0;
  arr.build_sa(130);
  arr.getHight();
  for(int i = 1; i <= n*2; ++i)
    if(arr.sa[i] < n)  printf("%c", arr.s[arr.sa[i]+n-1]);
  printf("\n");
  return 0;
}

  

BZOJ 1031 [JSOI2007]字符加密Cipher (後綴數組)