1. 程式人生 > >HDU-1102-Constructing Roads(最小生成樹)

HDU-1102-Constructing Roads(最小生成樹)

Problem Description   There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.  

 

Input   The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.  

 

Output   You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.   

 

Sample Input 3 0 990 692 990 0 179 692 179 0 1 1 2  

 

Sample Output 179
思路:克魯斯卡爾演算法唄。已經連的就merge()先處理一下。 坑點: 1.題沒說多組測試用例,但其實是多組... 2.剪枝的時候cnt初始值要注意一下,本題也可以不用剪枝。
#include<cstdio>
#include<algorithm>
using namespace std;
int N,Q;
int pre[105];

struct node{
    int a,b,len;    
}l[5000];

int find(int x){
    while(pre[x]!=x){
        int r=pre[x];
        pre[x]=pre[r];
        x=r;
    }
    return x;
}

void merge(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy) pre[fx]=fy;
}

int cmp(node x,node y){
    return x.len<y.len;
}

int main(){
    while(~scanf("%d",&N)){
    
        int cnt=0;
        int val;
        for(int i=1;i<=N;i++)
            pre[i]=i;
    
        for(int i=1;i<=N;i++){
            for(int j=1;j<=N;j++){
                scanf("%d",&val);
                if(j<=i) continue;
            
                l[cnt].a=i;
                   l[cnt].b=j;
                l[cnt].len=val;
                cnt++;            
            }
        }
        sort(l,l+cnt,cmp);
        scanf("%d",&Q);
        cnt=0;
        for(int i=0;i<Q;i++){
            int a,b;
            scanf("%d%d",&a,&b); 
            if(find(a)!=find(b)) {//這個要注意一下,因為a,b可能已經有路,也有可能被別的城市間接連起來了。//為了後邊剪枝 
            cnt++;  
            merge(a,b);
            }
        }
int sum=0; for(int i=0;i<N*(N-1)/2;i++){ if(cnt==N-1) break;//這個剪枝可以不要,也能AC if(find(l[i].a)==find(l[i].b)) continue; sum+=l[i].len; merge(l[i].a,l[i].b); cnt++; } printf("%d\n",sum); } return 0; }