1. 程式人生 > >ZOJ-1704-To The Max (字首和)

ZOJ-1704-To The Max (字首和)

原題: Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2

is in the lower left corner:

9 2 -4 1 -1 8

and has a sum of 15. Input The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127]. Output Output the sum of the maximal sub-rectangle. Sample Input 4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2 Sample Output 15 題意: 輸入一個n*n的矩陣,輸出矩陣中和最大的子矩陣的和。 題解: 利用字首和記錄每個點與(0,0)點之間的和,之後列舉所有的矩陣,利用字首和計算即可。(更多細節見程式碼) 附上AC程式碼:

#include <iostream>

using namespace std;
int num[105][105];
int sum[105][105];
int n;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            cin>>num[i][j];
            sum[i][j]=sum[i-1][j]+sum[i][j-1]-sum[i-1][j-1]+num[i][j];//計算每一個點字首和
        }
        int ans=-1e8;
        for(int i=0;i<=n;i++)//列舉所有的矩陣
        {
            for(int j=0;j<=n;j++)
            {
                for(int k=1;k<=n;k++)
                {
                    for(int m=1;m<=n;m++)
                    {
                        if(k>i&&m>j)//要求(k,m)必須大於(i,j),減少不必要的計算
                        {
                            int res=sum[k][m]-sum[k][j]-sum[i][m]+sum[i][j];//計運算元矩陣的和
                            if(res>ans)
                                ans=res;
                        }
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

歡迎評論!