1. 程式人生 > >HDU 1573 X問題(中國剩餘定理非互質情況)

HDU 1573 X問題(中國剩餘定理非互質情況)

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7866    Accepted Submission(s): 2835


 

Problem Description

求在小於等於N的正整數中有多少個X滿足:X mod a[0] = b[0], X mod a[1] = b[1], X mod a[2] = b[2], …, X mod a[i] = b[i], … (0 < a[i] <= 10)。

Input

輸入資料的第一行為一個正整數T,表示有T組測試資料。每組測試資料的第一行為兩個正整數N,M (0 < N <= 1000,000,000 , 0 < M <= 10),表示X小於等於N,陣列a和b中各有M個元素。接下來兩行,每行各有M個正整數,分別為a和b中的元素。

Output

對應每一組輸入,在獨立一行中輸出一個正整數,表示滿足條件的X的個數。

Sample Input

3 10 3 1 2 3 0 1 2 100 7 3 4 5 6 7 8 9 1 2 3 4 5 6 7 10000 10 1 2 3 4 5 6 7 8 9 10 0 1 2 3 4 5 6 7 8 9

Sample Output

1 0 3

PS:不互質的情況,我覺得可以去網上,找找,寫的好的部落格,看看,但下面這張圖就是中心思想。

AC程式碼:

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<vector>
const int maxn=1e2+5;
const int mod=1e9+7;
#define me(a) memset(a,0,sizeof(a))
typedef long long ll;
using namespace std;
ll n,m,a[maxn],b[maxn],x,y;int flog;
ll exgcd(ll a,ll b,ll &x,ll &y)
{
    if(!b)
    {
        x=1,y=0;
        return a;
    }
    ll gcd=exgcd(b,a%b,x,y);
    int temp=x;x=y;
    y=temp-a/b*y;
    return gcd;
}
void CRT()
{
    int a1=a[0],b1=b[0];
    for(int i=1;i<m;i++)
    {
        if(flog) continue ;
        ll a2=a[i],b2=b[i],c=b2-b1;
        int d=exgcd(a1,a2,x,y);
        if(c%d)
        {
            flog=1;continue ;
        }
        int t=a2/d;
        x=(x*c/d%t+t)%t;
        b1+=a1*x,a1*=a2/d;///更新解
    }
    if(b1>n||flog)
        cout<<"0"<<endl;
    else
    {
        ll ans=(n-b1)/a1+1;///a1為最小公倍數,a1*i+b1都滿足,b1是最小滿足情況的
        if(b1==0)
            ans--;
        cout<<ans<<endl;
    }
}
int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=0;i<m;i++)
            cin>>a[i];
        for(int i=0;i<m;i++)
            cin>>b[i];
        flog=0;CRT();
    }
    return 0;
}